Flux Health Forum

Software freezes

We’ve had trouble with the software freezing on the two computers on which I’ve tried it. The software has frozen a few times (maybe 5/10 times) while I was in the middle of testing (Win 10). The software also froze the first couple times my fiancé used the device on her computer (Win 8), in total 3 out of the 5 times she’s used it.

During these freezes, a number of things I tried did not restore functionality: button presses, disconnecting and reconnecting the device, and clicking “Pro” and then reselecting the same test.

Have others had trouble with this? Would there be a error log somewhere to take a look at?

Software froze on Duration Discrimination first test on level 5 this weekend. Using MacOS. Was able to still navigate the app by click top right icon and then click on the final hardware reaction test and that functioned properly. Was not able to go back to Duration Discrimination Level 5 without redoing it Duration Discrimination from the beginning.

1 Like

@TajD That was was essentially my experience as well, though I don’t remember which tests it froze on. I was able to continue with other tests as you indicated.

The technical support at Cortical Metrics is excellent. You should be able to call or email them directly and they will help you with this type of issue. Just contact them at:


email and phone number are at the bottom of that page.

1 Like

I’ve had the app glitch on me a few times, as well. I’m using MacOS and the home version of the Brain Gauge.

There appears to be a bug that prevents a new user from completing the first test (Hardware reaction time) immediately after creating their new user profile. Luckily this one has an easy work-around: create the new account, close & restart the app, and then launch the testing session for each new user.

I’ve only had the program crash midway through a testing session once - during the TOJ assessment. The buttons on my device became unoperational and the only thing I could do was restart the app and disconnect/ reconnect the device. Having done so, however, there is no option to re-start the test where you left off. I’ve now begun restarting my computer, reconnecting my device, and then launching the app before every testing session just to be on the safe side.

Strangely, I’ve also noticed that both buttons on my device become harder to press whenever I am completing the TOJ assessment. It’s a somewhat subtle difference but one that I’ve noticed increasingly since my device crashed during its TOJ assessment.

I’ll pass these observations along to the support team, of course, but thought it might be helpful for other users to get a sense for potentially recurring issues on this forum.


This is a quick follow-up to my last post. I just had the TOJ test freeze on its final round again, even though I’d restarted my laptop and re-attached my BG immediately prior to testing. (The BG’s buttons became inoperable and wouldn’t let me click to answer the question.) But I discovered that by selecting ‘pause test’ and then clicking on the subsequent test, I was at least able to complete the testing battery. And interestingly enough, my results for the TOJ assessment were right in line with most of my previous assessments, seeming to indicate that I’d been scored correctly nevertheless. Hope this helps!